前端开发您现在的位置是:首页 > 博客日志 > 前端开发

No matching version found for raphael@2.2.0-c.

<a href='mailto:'>微wx笑</a>的头像微wx笑2020-12-14 11:54:04前端开发人已围观关键字:   

Mac 下执行 npm install 时遇到错误,提示 No matching version found for raphael@2.2.0-c. 完整输出如下:sudo npm install --registry=https://registry.npm.taobao.orgPass

Mac 下执行 npm install 时遇到错误,提示 No matching version found for raphael@2.2.0-c. fzI编程技术_踩坑日志_进阶指南_无知人生


fzI编程技术_踩坑日志_进阶指南_无知人生

完整输出如下:

sudo npm install --registry=https://registry.npm.taobao.org
Password:
npm WARN read-shrinkwrap This version of npm is compatible with lockfileVersion@1, but package-lock.json was generated for lockfileVersion@2. I'll try to do my best with it!
npm WARN deprecated @hapi/address@2.1.4: This version has been deprecated and is no longer supported or maintained
npm WARN deprecated @hapi/hoek@8.5.1: This version has been deprecated and is no longer supported or maintained
npm WARN deprecated @hapi/joi@15.1.1: joi is leaving the @hapi organization and moving back to 'joi' (https://github.com/sideway/joi/issues/2411)
npm WARN deprecated core-js@2.6.12: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
npm WARN deprecated fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.
npm WARN deprecated har-validator@5.1.5: this
npm WARN deprecated highlight.js@9.18.5: Support has ended for 9.x series. Upgrade to @latest
npm WARN deprecated left-pad@1.3.0: use String.prototype.padStart()
npm ERR! code ETARGET
npm ERR! notarget No matching version found for raphael@2.2.0-c.
npm ERR! notarget In most cases you or one of your dependencies are requesting
npm ERR! notarget a package version that doesn't exist.

npm ERR! A complete log of this run can be found in:
npm ERR!     /Users/aven/.npm/_logs/2020-12-14T03_46_12_398Z-debug.log

原因分析

这要注意到第一行警告“This version of npm is compatible with lockfileVersion@1, but package-lock.json was generated for lockfileVersion@2. I'll try to do my best with it!”,此版本的npm与lockfileVersion @ 1兼容,但是package-lock.json 生成了lockfileVersion @ 2。我会尽力做到最好!fzI编程技术_踩坑日志_进阶指南_无知人生


fzI编程技术_踩坑日志_进阶指南_无知人生

这可能是使用了更高版本的 npm 创建了 package-lock.json 文件,但又切换为低版本的 npm 执行 npm install 命令。fzI编程技术_踩坑日志_进阶指南_无知人生

解决方法

删除 package-lock.json 文件,再执行 npm install 命令。fzI编程技术_踩坑日志_进阶指南_无知人生

但是执行 npm install 命令成功之后,再执行 npm run dev 命令还有可能遇到错误,我遇到的是:fzI编程技术_踩坑日志_进阶指南_无知人生

Error: Cannot find module 'body-parser'fzI编程技术_踩坑日志_进阶指南_无知人生

不过这也简单,执行以下命令安装一下就可以了:fzI编程技术_踩坑日志_进阶指南_无知人生

sudo npm install body-parser

顶起fzI编程技术_踩坑日志_进阶指南_无知人生

本文由 微wx笑 创作,采用 CC BY-NC 4.0 许可协议。 非商业性使用可自由转载、引用、甚至修改,但需署名作者且注明出处。

很赞哦! () 有话说 ()

相关文章