编程语言您现在的位置是:首页 > 博客日志 > 编程语言

binary_only = FormatControl(set(), {':all:'})

<a href='mailto:'>微wx笑</a>的头像微wx笑2019-11-05 14:26:37编程语言人已围观关键字:pip,python

简介执行pip安装python模块报错:binary_only = FormatControl(set(), {&#39;:all:&#39;})执行 python get-pip.py 安装pip也会报错分析报错的情况来看,是因为python的版本太低了,因

执行pip安装python模块报错:binary_only = FormatControl(set(), {':all:'})Pcb编程技术_踩坑日志_进阶指南 - 无知人生

执行 python get-pip.py 安装pip也会报错Pcb编程技术_踩坑日志_进阶指南 - 无知人生

分析报错的情况来看,是因为python的版本太低了,Pcb编程技术_踩坑日志_进阶指南 - 无知人生

因为执行 pip install --upgrade pip 时输出如下:Pcb编程技术_踩坑日志_进阶指南 - 无知人生

DEPRECATION: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of pip will drop support for Python 2.6
Collecting pip
  Downloading http://mirrors.aliyun.com/pypi/packages/00/b6/9cfa56b4081ad13874b0c6f96af8ce16cfbc1cb06bedf8e9164ce5551ec1/pip-19.3.1-py2.py3-none-any.whl (1.4MB)
    100% |████████████████████████████████| 1.4MB 67.5MB/s 
pip requires Python '>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*' but the running Python is 2.6.6
You are using pip version 9.0.3, however version 19.3.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

如果你的版本比我的高,那么可以试试:
Pcb编程技术_踩坑日志_进阶指南 - 无知人生

yum install python-pip -y
yum install python-setuptools -y

如果是,那恐怕需要安装 Python 高一点的版本了。
Pcb编程技术_踩坑日志_进阶指南 - 无知人生

如果是centOS系统,那么安装过程稍微麻烦一点。Pcb编程技术_踩坑日志_进阶指南 - 无知人生

参考;Pcb编程技术_踩坑日志_进阶指南 - 无知人生

CentOS release 6.10 下 Python 3.7.5 安装记录


Pcb编程技术_踩坑日志_进阶指南 - 无知人生

本文由 微wx笑 创作,采用 CC BY-NC 4.0 许可协议。 非商业性使用可自由转载、引用、甚至修改,但需署名作者且注明出处。

很赞哦! () 有话说 ()

站点信息

  • 建站时间:2018-10-24
  • 服务期限阿里云ECS 2027年到期
  • 主题模板:基于《今夕何夕》修改
  • 文章统计:244篇
  • 文章评论:16条
  • 文章阅读:5653次
  • 文章点赞:1309次
  • 微信公众号:扫描二维码,关注我们
  • 二维码-微信公众号-微wx笑